Keitboor

[Solution] Problème restriction graphique

54 messages dans ce sujet

Si vous avez des problèmes de restriction graphique, voici la solution :

 

  • Dans le repertoire de votre jeu (Par défaut : C:\Program Files\Rockstar Games\Grand Theft Auto IV) faites un clic droit sur LaunchGTAIV.exe, envoyer vers, bureau.
  • Une fois sur votre bureau, faites un clic droit sur le raccourci qu'on vient de créer.
  • Cliquez sur l'onglet Raccourci
  • Dans le champ de texte Cible, remplacez : "C:\Program Files\Rockstar Games\Grand Theft Auto IV\LaunchGTAIV.exe" par "C:\Program Files\Rockstar Games\Grand Theft Auto IV\LaunchGTAIV.exe" -norestrictions
  • Appliquer, ok.
  • Double-cliquez sur votre raccourci

 

 

La liste complète des options de lancement :

 

Tools:

-benchmark: Runs the benchmark tool and immediately exits game.

-help: Display list of all command line options

 

Graphics:

-renderquality: Set the render quality of the game. (0-4)

-shadowdensity: Set the shadow density of the game. (0-16)

-texturequality: Set the texture quality of the game. (0-2)

-viewdistance: Set the view distance of the game (0-99)

-detailquality: Set the detail quality of the game. (0-99)

-novblank: Disable wait for vblank (No Vsync)

-norestrictions: Do not limit graphics settings

-width: Set width of main render window (default is 800)

-height: Set height of main render window (default is 600)

-safemode: Run the graphics in the lowest setting possible

-frameLimit: Limit frame to interval of refresh rate

(ex If refreshrate is 60HZ –frameLimit 1 = Locks down to 60HZ)

-refreshrate: Set the refresh rate of main render window

– Warning - Monitor must support (ex. –refreshrate 60)

-fullscreen: Force fullscreen mode

-windowed: Force windowed mode

-availablevidmem: Set amount of physical Video Memory(ex. –availablevidmem 0.9)

-percentvidmem: Percentage of video memory to make available to GTA

 

Audio:

-fullspecaudio: Force high-end CPU audio footprint

-minspecaudio: Force low-end CPU audio footprint

 

System:

-noprecache: Disable precache of resources

-nomemrestrict: Disable memory restrictions

 

Pour ajouter plusieurs options, il suffit de les séparer par des espaces, exemple :

 

-norestrictions -noprecache

 

0

Partager ce message


Lien à poster
Partager sur d’autres sites

J'ai essayer cette solution ce matin, et bizarrement, en débloquant ces options, j'ai pu tout mettre à fond, et le jeu marche mieux ^^

 

Avant sa ramait un poil à certain moment, maintenant plus du tout...

0

Partager ce message


Lien à poster
Partager sur d’autres sites

j'ai essayer et ca change rien .Je comprends pas

0

Partager ce message


Lien à poster
Partager sur d’autres sites
j'ai essayer et ca change rien .Je comprends pas

Bah pour moi non plus sa ne marche pas j'ai mis exactement ceci: "C:\Program Files\Rockstar Games\Grand Theft Auto IV\LaunchGTAIV.exe" -norestriction -renderquality 3 -shadowdensity 12 -texturequality 2 -viewdistance 60 -detailquality 60 , dans "cible" et quand je lance le jeu sa ne change rien et le norestrictions ne fonctionne pas je peux toujours pas augmenter au dessus de 292M

0

Partager ce message


Lien à poster
Partager sur d’autres sites

-norestrictions avec un "s" tu n'en a pas mis ;)

0

Partager ce message


Lien à poster
Partager sur d’autres sites
-norestrictions avec un "s" tu n'en a pas mis ;)

ouaip je sais mais j'ai essayé aussi sa fait exactement la meme chose. Ce que je ne comprend pas à cette commande c'est que lorsqu'on met ces commandes on ne doit plus se servir de l'option du jeu pour changer les graphismes?

0

Partager ce message


Lien à poster
Partager sur d’autres sites
ouaip je sais mais j'ai essayé aussi sa fait exactement la meme chose. Ce que je ne comprend pas à cette commande c'est que lorsqu'on met ces commandes on ne doit plus se servir de l'option du jeu pour changer les graphismes?

Et coté resolution "C:\Program Files\Rockstar Games\Grand Theft Auto IV\LaunchGTAIV.exe" -norestrictions -renderquality 4 -shadowdensity 16 -texturequality 2 -viewdistance 99 -detailquality 99 -width 1400 -height 900 . J'ai mis tout sa dans le raccourci et je suis toujours en 800 600 et impossible de me mettre en 1400 900. Merci d'avance pour une reponse qui puisse me faire avancer ;)

0

Partager ce message


Lien à poster
Partager sur d’autres sites

j'ai beau avoir ajouter le norestrictions à la fin je peux pas tout mettre comme je le veux.

0

Partager ce message


Lien à poster
Partager sur d’autres sites
Et coté resolution "C:\Program Files\Rockstar Games\Grand Theft Auto IV\LaunchGTAIV.exe" -norestrictions -renderquality 4 -shadowdensity 16 -texturequality 2 -viewdistance 99 -detailquality 99 -width 1400 -height 900 . J'ai mis tout sa dans le raccourci et je suis toujours en 800 600 et impossible de me mettre en 1400 900. Merci d'avance pour une reponse qui puisse me faire avancer ;)

Il faut utiliser les options de cette façon-là : -renderquality=4

Sinon ça ne marchera pas.

 

Sinon je pense que c'est l'option -nomemrestrict qui permet d'aller au-delà de la capacité mémoire indiquée par le jeu, essaye de la combiner avec -norestrictions.

 

EDIT : de plus pour que ça fonctionne tu dois être connecté au social club depuis l'application de Rockstar, sinon il ne fait que te lancer le social club

Modifié par Excelsior
0

Partager ce message


Lien à poster
Partager sur d’autres sites
Il faut utiliser les options de cette façon-là : -renderquality=4

Sinon ça ne marchera pas.

 

Sinon je pense que c'est l'option -nomemrestrict qui permet d'aller au-delà de la capacité mémoire indiquée par le jeu, essaye de la combiner avec -norestrictions.

 

EDIT : de plus pour que ça fonctionne tu dois être connecté au social club depuis l'application de Rockstar, sinon il ne fait que te lancer le social club

Non c'est bon la solution a été trouvé sur jeux vidéo.com!

 

"Bonjour les petits potes j'ai trouver la solution pour tout ceux qui comme moi malgré le -norestriction ont toujours un jeux bloquer en moyen voir faible.

 

La manip est simple.Suivez les etapes point par point

1-Faites un raccourci sur votre bureau de LaunchGTAIV

2-Rajouter à la cible le norestriction et vous avez donc la ligne comme ceci

"C:\Program Files\Rockstar Games\Grand Theft Auto IV\LaunchGTAIV.exe" -norestrictions

-Creer un fichier block note et copier dedans ceci

 

-texturequality=2 -renderquality=4 -detailquality=98 -viewdistance=98 -width=1680 -height=1050 -shadowdensity=16 -norestrictions -norestriction -nomemrestrict -percentvidmem=99 -availablevidmem=1.3

 

3-tout doit y etre avec les "-" comprit ok? vous nommerez le fichier commandline et vous l'enregistrer sur le bureau .Et la vous avez sur votre bureau le racourci LaunchGTAIV et le commanline.

 

4-Ensuite copier coller le commandline dans votre dossier GTA,il faut le placer de la maniére suivante,il faut qu'il soit entre le LaunchGTAIV.exe et le paul.dll

 

5-Clicker sur LaunchGTAIV du dossier ou du bureau,le jeu se lance et la tout serra déjà régler au maximum,et vous pourrez biensure baisser si c'est trop pour votre machine."

 

voila,si il y a des questions allez y.

++

0

Partager ce message


Lien à poster
Partager sur d’autres sites

je confirme ca marche par contre faut se connecter a rockstar bidule chouette.Mais le patch s'impose quand meme .Ouais ben parler trop vite ca a marcher qu'une seule fois

Modifié par fred58
0

Partager ce message


Lien à poster
Partager sur d’autres sites
je confirme ca marche par contre faut se connecter a rockstar bidule chouette.Mais le patch s'impose quand meme .Ouais ben parler trop vite ca a marcher qu'une seule fois

Ouaip on veut le patch la Rockstar ;) mais sinon sa marche sof la resolution :microchiottes:

0

Partager ce message


Lien à poster
Partager sur d’autres sites

bon ben ca remarche mais vaut mieux que je laisse ca au minimum sinon le decor disparait les voiture ne sont plus coller a la route

0

Partager ce message


Lien à poster
Partager sur d’autres sites
bon ben ca remarche mais vaut mieux que je laisse ca au minimum sinon le decor disparait les voiture ne sont plus coller a la route

La même pour moi je sais pas pourquoi en 800 600 aucun prob et en 1400 900 tout disparait xD

0

Partager ce message


Lien à poster
Partager sur d’autres sites
bon ben ca remarche mais vaut mieux que je laisse ca au minimum sinon le decor disparait les voiture ne sont plus coller a la route

 

J'ai également ce problème sur mon PC Portable, c'est dû à un manque de mémoire. Pour le moment à part baisser les options graphiques il n'y a pas d'autres alternatives.

0

Partager ce message


Lien à poster
Partager sur d’autres sites

Super astuce , je te remercie , depuis le jeux passe a fond sans bug , enfin presque plus =D ;)

0

Partager ce message


Lien à poster
Partager sur d’autres sites
Super astuce , je te remercie , depuis le jeux passe a fond sans bug , enfin presque plus =D ;)

hih y'aa pas de quoi surtout merci a celui qui a trouvé l'astuce sur jeux vidéo.com :microchiottes:

0

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !


Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.


Connectez-vous maintenant