• Annonces

    • BenDeR

      Thème des Fêtes 2017   06/12/2017

      Encore cette année, l'ambiance festive est au rendez-vous sur les forums avec l'arrivée de la neige et du Thème des Fêtes. Habillez-vous chaudement, contrairement à notre mascotte Natacha, qui a encore une fois été complètement maboule. Pour réagir : https://www.gtanf.com/forums/topic/36487-thème-des-fêtes-2017/  
Montecarlo62

Dysfonctionnement du mod Addonpeds

Recommended Posts

Bonsoir,

 

Je ne parviens pas à faire fonctionner le mod Addonpeds. Dans le descriptif, il est précisé de télécharger le fichier Script Hook V.NET et de débloquer ScriptHookVDotNet2.dll à travers le menu Propriétés. Le problème est que sous Windows 10, il n'existe pas de bouton Unblock dans le menu des propriétés.

 

Lorsque j'appuie sur la touche  L  il ne se passe rien !

 

Quelqu'un a t'il la solution ?

 

Merci

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonsoir,

 

Pour information, voici ce que j'obtiens dans le fichier log de ScriptHookVDotNet2 :

 

Failed to instantiate script 'PedSelector.PedSelector' because constructor threw an exception:
System.MissingMethodException: Méthode introuvable : 'NativeUI.UIMenu NativeUI.MenuPool.AddSubMenu(NativeUI.UIMenu, System.String, System.String)'.
   à PedSelector.PedSelector.AddonPedsMenu(UIMenu Menu)
   à PedSelector.PedSelector..ctor()

 

Peut-être est-ce un problème concernant le fichier NativeUI.dll ?

 

Quelqu'un peut m'aider car j'aimerais bien faire fonctionner ce mod qui m'a l'air assez fun !

 

Montecarlo62

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonsoir Mimile,

 

Désolé mais je ne trouve pas le fichier NativeUI.dll dans le lien que tu m'a transmis.

 

Voici ce que j'obtiens après avoir décompressé le fichier zip :

 

Dans le dossier GTA V Menu Template se trouve :

 

un sous dossier Properties contenant le fichier AssemblyInfo.cs

 

_PreviewImage.ico

_TemplateIcon.ico.cs

class.cs

GTAVMenuTemplate.csproj

MyTemplate.vstemplate

 

Voilà ! Je ne sais pas à quoi ces fichiers se réfèrent mais point de NativeUI.dll

 

Peux-tu me transmettre un autre lien pour télécharger ce fichier et me dire s'il est préférable d'installer la version 2.2 ou la plus récente d'addonPeds à savoir la 3.0.1

 

Merci d'avance

 

Montecarlo62

 

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonsoir,

En effet, le lien que je t'ai transmis ne contenait pas NativeUI, au temps pour moi.

 

Le 05/12/2017 à 22:51, Montecarlo62 a dit :

Dans le descriptif, il est précisé de télécharger le fichier Script Hook V.NET et de débloquer ScriptHookVDotNet2.dll à travers le menu Propriétés. Le problème est que sous Windows 10, il n'existe pas de bouton Unblock dans le menu des propriétés.

En effet, le déblocage du fichier n'est, en principe, plus nécessaire. J'ai mis à jour la fiche du mod.

 

Pour ce qui est de NativeUI donc, je vois qu'il ne figure pas dans l'archive de AddonPeds, je t'invite donc à essayer d'installer AddonPeds sans NativeUI (même s'il figure dans les fichiers requis, donc ça ne devrait pas fonctionner...). Autrement, tu peux télécharger NativeUI directement sur GTAForums.

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonsoir Mimile,

 

Je viens de télécharger le fameux fichier NativeUI.dll que j'ai mis dans le dossier script comme indiqué avec le fichier Pedselector.dll .

 

Il y a un léger mieux à savoir que le menu Ped Selector s'ouvre désormais en appuyant sur la touche L mais aucun des modèles contenus dans le dlc.rpf du dossier addonpeds ne fonctionne et cela m'indique invalid model.

 

Je précise que dans le dossier Scripts , il n'y a que ces deux fichiers. Par conséquent, il ne peut pas y avoir de conflit avec un autre mod.

 

Pensant que le problème provenait des deux fichiers peds fournis dans addonped, j'ai rajouté deux autres modèles : Wonder Woman et T-Rex en n'oubliant pas de faire Rebuild dans l'Addonpedseditor mais le problème est identique.

 

Rien ne s'ouvre à mon grand regret !

 

As-tu une idée sachant que j'ai bien tout téléchargé comme demandé à savoir Script Hook V, ASI Loader, Script Hook V.NET et OpenIV et que les mises à jours au niveau des Microsoft Visual C++ sont présentes.

 

J'ai d'ailleurs tenté de le faire fonctionner sous deux OS différents : Windows 10 Pro 64 bits et Windows 8.1 Familial mais le problème est insoluble.

 

Dans l'attente d'une solution.

 

Bonne soirée.

 

Montecarlo62

 

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour, 

Vérifie que tu n'as pas fait d'erreurs lors de l'installation des add-ons (notamment le fait qu'il ne faut pas mettre l'extension des fichiers lorsqu'on ajoute un modèle dans le menu). As-tu bien installé OpenIV.asi ? 

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonsoir Mimile38,

 

Concernant Open IV.asi, j'ai installé la dernière version à savoir 2.9.1 (Build926; Date 05/10/2017)

 

Pour les fichiers Peds, je te transmets quatre captures écran : trois réalisées sous Open IV dans le fichier mods et la quatrième au niveau du Ped Selector mais apparemment les fichiers sont bien nommés.

 

Je ne vois vraiment pas d'où peut provenir le problème.

 

1512764048-capture-ecran-gta-v-developpe

 

1512764043-capture-ecran-gta-v-dossier-d

 

1512764043-capture-ecran-gta-v-dossier-m

 

1512764043-capture-ecran-gta-v-menu-addo

 

 

Merci d'avance pour ta réponse.

 

 

Montecarlo62

 

 

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Oui je l'ai déjà installé, mais je n'ai jamais rencontré ce problème. En plus je l'avais testé avec le mod T-Rex, que toi aussi tu as installé apparemment, et ça marchait pour moi :huh:

Partager ce message


Lien à poster
Partager sur d’autres sites

Merci de tes réponses en tout cas.

 

Apparemment, à la lecture de différents forums, je ne suis pas le seul à rencontrer ce problème avec ce mod.

 

Soit la touche L n'a aucun effet soit le menu Ped Selector s'ouvre mais il n'y a aucun moyen de charger les modèles.

 

J'espère trouver une solution .

 

Sinon, à ta connaissance, y-a t'il d'autres mods fonctionnels permettant de charger des nouveaux "personnages" ?

 

 

 

Montecarlo62

 

 

 

 

 

 

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

Tu peux essayer de remplacer des personnages déjà existants. Dans notre base de données, il y a des personnages qui s'installent par "remplacement", tu peux t'inspirer des instructions d'installation de ces mods, en renommant les fichiers du personnage que tu veux ajouter. C'est du bricolage, mais ça peut fonctionner.

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant