[TUTO] Installer un mod de type .asi

14 messages dans ce sujet

Posté(e)

Suite à la demande d'un tutoriel des mods .asi, en voici un:

 

1. le téléchargement requis et le mod .asi

 

Alors, il vous faut l'ASI LOADER, sans ça, vos mods .asi ne marcheront pas. Vous pouvez le trouver ici.

 

Le mod

 

Prenez un mod .asi (dans cet exemple, je vais prendre Simple Trainer Pour GTAIV, que vous pouvez trouver ici.

 

2 L'installation du mod

 

Bon, maintenant, après avoir téléchargé Asi loader et le mod:

 

Dans Asi loader, vous trouverez un fichier du nom de dsound.dll qu'il faudra extraire vers C:\Program Files\Rockstar Games\Grand Theft Auto IV (par défaut).

 

Bon, maintenant, ouvrez le mod que vous avez téléchargé. Il faut extraire tous ces fichiers (dans mon cas):

 

-ScriptHook.dll

-ScriptHook.dll - OLD PATCH

-ScriptHook.dll LICENSE

-Trainers.asi

-Trainers.ini

-Trainerstbogt.asi (si vous avez Grand Theft Auto 4 : The Ballad of Gay Tony)

-Trainerstbogt.ini (si vous avez Grand Theft Auto 4 : The Ballad of Gay Tony)

-Trainerstlad.asi (si vous avez Grand Theft Auto IV: The Lost and Damned)

-Trainerstlad.ini (si vous avez Grand Theft Auto IV: The Lost and Damned)

 

Extraire ces fichiers vers C:\Program Files\Rockstar Games\Grand Theft Auto IV (par défaut).

 

Voilà, maintenant, lancez le jeu normalement et amusez-vous bien!

0

Partager ce message


Lien à poster
Partager sur d’autres sites

Posté(e)

Salut al916,

 

Merci d'avoir pris le temps de rédiger ce tutoriel. ;)

J'ai épinglé ton topic et corrigé les quelques fautes pour plus de clarté.

0

Partager ce message


Lien à poster
Partager sur d’autres sites

Posté(e)

si sa marche je t'embrasse des 2 cotés mouhahaahahha

0

Partager ce message


Lien à poster
Partager sur d’autres sites

Posté(e)

il c passe rien ouinnnnn personne pour m'aider

0

Partager ce message


Lien à poster
Partager sur d’autres sites

Posté(e) (modifié)

quel mod a tu pris, si tu a pris mon mod appuis sur f3 et puis appuie sur

2 bas

4 gauche

6 droite

8 haut

5 entrer dans le sous menu

et puis si toujour rien ne marche recommence tout depuis le début du tuto

Modifié (le) par al916
0

Partager ce message


Lien à poster
Partager sur d’autres sites

Posté(e) (modifié)

J'ai tout fais comme dans ton tuto mais quand je télécharge une dossier (le mod par exemple) bah je peux l'ouvrir q'avec internet explorer. Donc pour moi sa marche pas. Ce tute marche aussi pour Episode From Liberty City?

Modifié (le) par titom
0

Partager ce message


Lien à poster
Partager sur d’autres sites

Posté(e) (modifié)

J'ai tout fais comme dans ton tuto mais quand je télécharge une dossier (le mod par exemple) bah je peux l'ouvrir q'avec internet explorer. Donc pour moi sa marche pas. Ce tute marche aussi pour Episode From Liberty City?

oui sa marche avec Episode From Liberty City

Modifié (le) par al916
0

Partager ce message


Lien à poster
Partager sur d’autres sites

Posté(e)

le jeux ne se lance pas

0

Partager ce message


Lien à poster
Partager sur d’autres sites

Posté(e)

Cela ne marche pas, impossible de lancer le mod. J'ai tout fait comme le tuto et une fois dans le jeux il ne se passe rien. Même en faisant F3 2,4,6,8,5

0

Partager ce message


Lien à poster
Partager sur d’autres sites

Posté(e)

bonjour à tous,

J'ai un peu le même problème pour le coup, il ne se passe rien! :D;) ;)

J'ai bien mis le dsound.dll du asi loader dans le dossier de gta4,

j'ai également mis mon mod (pour mon cas c'est le piegonsdetectorplus.dll )..

Le jeu se lance nikel, mais aprés j'ai beau taper F3 ou F4, en pause ou pas, rien n'y fait,

et il ne se passe absolument rien..

Il me reste 1 seul piegon à éclater, ce mod m'aurait bien été utile..

pour info (et je pense que ca atteste bien que l'asi loader est installé),

en cours de partie, et depuis même quand je ferme le jeu,

j'ai un fichier asilog.txt qui c'est créer dans le dossier du jeu, est dans ce fichier j'ai ceci:

// -- GTA IV ASI LOADER LOG -- //

//-- © Alexander Blade 2008 -- //

C:\Windows\system32\dsound.dll is loaded, address 0x73920000

Hooking dsound proc named "DirectSoundCreate"

"DirectSoundCreate" hooked, address 0x73927E3D

Hooking dsound proc named "DirectSoundEnumerateA"

"DirectSoundEnumerateA" hooked, address 0x7396D993

Hooking dsound proc named "DirectSoundEnumerateW"

"DirectSoundEnumerateW" hooked, address 0x7396D9B0

Hooking dsound proc named "DllCanUnloadNow"

"DllCanUnloadNow" hooked, address 0x739541BB

Hooking dsound proc named "DllGetClassObject"

"DllGetClassObject" hooked, address 0x73927792

Hooking dsound proc named "DirectSoundCaptureCreate"

"DirectSoundCaptureCreate" hooked, address 0x7396D2C5

Hooking dsound proc named "DirectSoundCaptureEnumerateA"

"DirectSoundCaptureEnumerateA" hooked, address 0x7396D9CD

Hooking dsound proc named "DirectSoundCaptureEnumerateW"

"DirectSoundCaptureEnumerateW" hooked, address 0x7396D9EA

Hooking dsound proc named "GetDeviceID"

"GetDeviceID" hooked, address 0x7396D160

Hooking dsound proc named "DirectSoundFullDuplexCreate"

"DirectSoundFullDuplexCreate" hooked, address 0x7396D429

Hooking dsound proc named "DirectSoundCreate8"

"DirectSoundCreate8" hooked, address 0x7395DE69

Hooking dsound proc named "DirectSoundCaptureCreate8"

"DirectSoundCaptureCreate8" hooked, address 0x7396D371

Loading ASI C:\Program Files (x86)\Rockstar Games\Grand Theft Auto IV\PigeonsDetectorPlus.asi

ASI loaded : C:\Program Files (x86)\Rockstar Games\Grand Theft Auto IV\PigeonsDetectorPlus.asi, Address 0x6DF10000

Donc il me semble que tout à fonctionné, je veux dire l'asi est bien chargé dans le jeu,

mais pourquoi quand je tape F3 ou F4 rien ne s'affiche??

Si quelqu'un peut m'aider, ca serai super cool!!

config: je tourne sous windows 7 et le jeu à été mis à jour aprés install, je suis sur la version 1.0.7.0 de gta4.

est ce que asiloader et les mods en général sont comptatible avec les patchs de mise à jour??

0

Partager ce message


Lien à poster
Partager sur d’autres sites

Posté(e)

J'ai également un fichier pigeonsdetectorplus.log qui c'est créée, et dedant il y a:

Log start: Fri Oct 01 12:29:26 2010

-----------------------------------------------

[iNFO] ********************************

[iNFO] Pingeons Detector Plus v1.1

[iNFO] Made by koolk

[iNFO] ********************************

[iNFO] GTA IV Script Hook 0.2.1 - © 2009, Aru - Initialized

[iNFO] Process base address: 0xa30000

[iNFO] Unable to autodetect game version, defaulting to 1.0.3

[iNFO] Awaiting game thread creation

[iNFO] Starting custom threads

[iNFO] [PigeonsDetector] Thread started

[iNFO] [stuntsDetector] Thread started

[iNFO] Script Hook - Shutdown

Donc en gros ca veux charger, mais cela ne reconnait pas ma version de gta car ce .asi est pour la version 1.0.3..

Donc si ca marche pas chez vous aussi, vérifier la version de votre gta4, apparement certaint mod ne fonctionne pas avec la dernière mise à jour du jeu..

Faut demander à qui pour avoir un PigeonsDetector pour GTA4 ver 1.0.7.0 ?? :D

0

Partager ce message


Lien à poster
Partager sur d’autres sites

Posté(e)

moi le probleme c'est que je n'arrive pas a l'extraire ou tu demande

0

Partager ce message


Lien à poster
Partager sur d’autres sites

Posté(e)

THANK

0

Partager ce message


Lien à poster
Partager sur d’autres sites

Posté(e)

Cela ne marche pas, impossible de lancer le mod. J'ai tout fait comme le tuto et une fois dans le jeux il ne se passe rien. Même en faisant F3 2,4,6,8,5

faut appuyer su F4.

0

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !


Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.


Connectez-vous maintenant

  • En ligne récemment   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.